summaryrefslogtreecommitdiff
path: root/ports/dash/port
diff options
context:
space:
mode:
authordzwdz2023-06-25 16:38:32 +0200
committerdzwdz2023-06-25 16:38:32 +0200
commitd4542c336a6cbfb43497055f19a85e7713f2eed7 (patch)
tree9f4a68974c3392b0ea546ecc94324911e86f0528 /ports/dash/port
parentfffd37f1680664bf055d8f5603ed1967718a6492 (diff)
ports: reimplement the ports system from scratch
side stuff: * removed sltar since it wasn't working anyways * made signal() no longer panic, as that broke certain ports (oops) * doom now ships with the FreeDOOM WADs * /usr/ was aliased to /init/usr/, more directories were added to /bin/ to improve compat with ports
Diffstat (limited to 'ports/dash/port')
-rwxr-xr-xports/dash/port18
1 files changed, 18 insertions, 0 deletions
diff --git a/ports/dash/port b/ports/dash/port
new file mode 100755
index 0000000..6a17372
--- /dev/null
+++ b/ports/dash/port
@@ -0,0 +1,18 @@
+#!/bin/sh
+. ports/pre
+
+pkg=dash
+tarball=dash-0.5.12.tar.gz
+tarball_dir=dash-0.5.12
+url=http://gondor.apana.org.au/~herbert/dash/files/${tarball}
+
+relink() {
+ rm $tarball_dir/dash
+}
+
+configure() {
+ test -e $tarball_dir/Makefile && return
+ (cd $tarball_dir && ./configure --host=x86_64-camellia)
+}
+
+. ports/post