summaryrefslogtreecommitdiff
path: root/ports/dash
diff options
context:
space:
mode:
authordzwdz2023-06-25 16:38:32 +0200
committerdzwdz2023-06-25 16:38:32 +0200
commitd4542c336a6cbfb43497055f19a85e7713f2eed7 (patch)
tree9f4a68974c3392b0ea546ecc94324911e86f0528 /ports/dash
parentfffd37f1680664bf055d8f5603ed1967718a6492 (diff)
ports: reimplement the ports system from scratch
side stuff: * removed sltar since it wasn't working anyways * made signal() no longer panic, as that broke certain ports (oops) * doom now ships with the FreeDOOM WADs * /usr/ was aliased to /init/usr/, more directories were added to /bin/ to improve compat with ports
Diffstat (limited to 'ports/dash')
-rw-r--r--ports/dash22
-rwxr-xr-xports/dash/port18
-rw-r--r--ports/dash/sha256sums1
3 files changed, 19 insertions, 22 deletions
diff --git a/ports/dash b/ports/dash
deleted file mode 100644
index aa15435..0000000
--- a/ports/dash
+++ /dev/null
@@ -1,22 +0,0 @@
-set -eu
-camellia_path_check
-
-VERSION=dash-0.5.12
-
-fetch() {
- wget -nc https://gondor.apana.org.au/~herbert/dash/files/dash-0.5.12.tar.gz
- echo "6a474ac46e8b0b32916c4c60df694c82058d3297d8b385b74508030ca4a8f28a dash-0.5.12.tar.gz" | sha256sum --check
- tar xf ${VERSION}.tar.gz
-}
-
-prep() {
- [ -d ${VERSION} ] || (fetch)
- cd ${VERSION}
- [ -e Makefile ] || ./configure CC=x86_64-camellia-gcc "CFLAGS=-Wno-error=format -Wno-error=unused-but-set-variable" --prefix"=$PREFIX" --host=x86_64-camellia
-}
-
-case $1 in
- install) (prep; make; make install) ;;
- clean) (prep; make clean) ;;
- *) echo "usage: $0 install|clean"; false ;;
-esac
diff --git a/ports/dash/port b/ports/dash/port
new file mode 100755
index 0000000..6a17372
--- /dev/null
+++ b/ports/dash/port
@@ -0,0 +1,18 @@
+#!/bin/sh
+. ports/pre
+
+pkg=dash
+tarball=dash-0.5.12.tar.gz
+tarball_dir=dash-0.5.12
+url=http://gondor.apana.org.au/~herbert/dash/files/${tarball}
+
+relink() {
+ rm $tarball_dir/dash
+}
+
+configure() {
+ test -e $tarball_dir/Makefile && return
+ (cd $tarball_dir && ./configure --host=x86_64-camellia)
+}
+
+. ports/post
diff --git a/ports/dash/sha256sums b/ports/dash/sha256sums
new file mode 100644
index 0000000..b109276
--- /dev/null
+++ b/ports/dash/sha256sums
@@ -0,0 +1 @@
+6a474ac46e8b0b32916c4c60df694c82058d3297d8b385b74508030ca4a8f28a dash-0.5.12.tar.gz