summaryrefslogtreecommitdiff
path: root/ports/oed/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports/oed/files/Makefile')
-rw-r--r--ports/oed/files/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/ports/oed/files/Makefile b/ports/oed/files/Makefile
new file mode 100644
index 0000000..929fddb
--- /dev/null
+++ b/ports/oed/files/Makefile
@@ -0,0 +1,32 @@
+# This Makefile automatically generated by configure.
+
+CC = x86_64-camellia-gcc
+CFLAGS = -g -O2 -I. -D_GNU_SOURCE
+
+PREFIX = /usr/local
+MANDIR = /usr/local/man
+
+PROG = ed
+OBJS = buf.o glbl.o io.o main.o re.o sub.o undo.o \
+ regcomp.o regerror.o regexec.o regfree.o \
+ reallocarray.o strlcat.o strlcpy.o
+
+all: ${PROG}
+
+${PROG}: ${OBJS}
+ ${CC} ${LDFLAGS} -o ${PROG} ${OBJS}
+
+install:
+ install -d ${DESTDIR}${PREFIX}/bin
+ install -d ${DESTDIR}${MANDIR}/man1
+ install -c -s -m 755 ${PROG} ${DESTDIR}${PREFIX}/bin
+ install -c -m 644 ed.1 ${DESTDIR}${MANDIR}/man1/${PROG}.1
+
+test:
+ @echo "No tests"
+
+clean:
+ rm -f ${PROG} ${OBJS}
+
+distclean: clean
+ rm -f Makefile config.h