summaryrefslogtreecommitdiff
path: root/ports/oed
diff options
context:
space:
mode:
Diffstat (limited to 'ports/oed')
-rw-r--r--ports/oed/files/Makefile32
-rw-r--r--ports/oed/files/config.h5
-rwxr-xr-xports/oed/port13
-rw-r--r--ports/oed/sha256sums1
4 files changed, 51 insertions, 0 deletions
diff --git a/ports/oed/files/Makefile b/ports/oed/files/Makefile
new file mode 100644
index 0000000..929fddb
--- /dev/null
+++ b/ports/oed/files/Makefile
@@ -0,0 +1,32 @@
+# This Makefile automatically generated by configure.
+
+CC = x86_64-camellia-gcc
+CFLAGS = -g -O2 -I. -D_GNU_SOURCE
+
+PREFIX = /usr/local
+MANDIR = /usr/local/man
+
+PROG = ed
+OBJS = buf.o glbl.o io.o main.o re.o sub.o undo.o \
+ regcomp.o regerror.o regexec.o regfree.o \
+ reallocarray.o strlcat.o strlcpy.o
+
+all: ${PROG}
+
+${PROG}: ${OBJS}
+ ${CC} ${LDFLAGS} -o ${PROG} ${OBJS}
+
+install:
+ install -d ${DESTDIR}${PREFIX}/bin
+ install -d ${DESTDIR}${MANDIR}/man1
+ install -c -s -m 755 ${PROG} ${DESTDIR}${PREFIX}/bin
+ install -c -m 644 ed.1 ${DESTDIR}${MANDIR}/man1/${PROG}.1
+
+test:
+ @echo "No tests"
+
+clean:
+ rm -f ${PROG} ${OBJS}
+
+distclean: clean
+ rm -f Makefile config.h
diff --git a/ports/oed/files/config.h b/ports/oed/files/config.h
new file mode 100644
index 0000000..bad56a1
--- /dev/null
+++ b/ports/oed/files/config.h
@@ -0,0 +1,5 @@
+/* This file automatically generated by configure. */
+
+extern void *reallocarray(void *, size_t, size_t);
+extern size_t strlcat(char *, const char *, size_t);
+extern size_t strlcpy(char *, const char *, size_t);
diff --git a/ports/oed/port b/ports/oed/port
new file mode 100755
index 0000000..425407e
--- /dev/null
+++ b/ports/oed/port
@@ -0,0 +1,13 @@
+#!/bin/sh
+. ports/pre
+
+pkg=oed
+tarball=oed-7.1.tar.gz
+tarball_dir=oed-oed-7.1
+url=https://github.com/ibara/oed/archive/refs/tags/$tarball
+
+relink() {
+ rm $tarball_dir/ed
+}
+
+. ports/post
diff --git a/ports/oed/sha256sums b/ports/oed/sha256sums
new file mode 100644
index 0000000..2e15fde
--- /dev/null
+++ b/ports/oed/sha256sums
@@ -0,0 +1 @@
+227ad4e6e9d2adb3a4b743c8ad3a50bcda63dea146d41bd6cbd8b79f495b057b oed-7.1.tar.gz